Status page innacuracies
Incident Report for Left4Craft
Postmortem

The issue was manually resolved.

Posted Apr 23, 2021 - 18:52 UTC

Resolved
Due to an issue with our automation system, the Party Games server was wrongly reported as offline for the past two weeks.
Posted Apr 23, 2021 - 23:00 UTC